易语言快速判断数组中的数值源码

.版本 2

.程序集 窗口程序集1
.程序集变量 数值数组, 整数型, , “0”

.子程序 是否在数值数组内, 整数型, , 返回数值个数
.参数 数值数组, 整数型, 参考 数组
.参数 数值, 整数型
.参数 数值位置, 整数型, 参考 可空 数组, 返回该数值在数组内的位置
.局部变量 数值数组字节集, 字节集
.局部变量 长度, 整数型
.局部变量 i, 整数型
.局部变量 字节集数据, 字节集
.局部变量 数量, 整数型
清除数组 (数值位置)
字节集数据 = 到字节集 (数值)
长度 = 取数组成员数 (数值数组) × 4
数值数组字节集 = 取空白字节集 (长度)
拷贝内存_ (数值数组字节集, 数值数组, 长度)
i = 寻找字节集 (数值数组字节集, 字节集数据, 0)
.判断循环首 (i > -1)
.如果真 (i % 4 = 1)
加入成员 (数值位置, i \ 4 + 1)
数量 = 数量 + 1
.如果真结束
i = 寻找字节集 (数值数组字节集, 字节集数据, i + 1)
.判断循环尾 ()
返回 (数量)
.子程序 _按钮1_被单击
.局部变量 个数, 整数型
.局部变量 i, 整数型

个数 = 到数值 (编辑框_个数.内容)
重定义数组 (数值数组, 假, 到数值 (编辑框_个数.内容))
列表框_源.清空 ()
列表框_结果.清空 ()
置随机数种子 (取启动时间 ())
列表框_源.禁止重画 ()
.变量循环首 (1, 个数, 1, i)
数值数组 [i] = 取随机数 (1, 10000)
列表框_源.加入项目 (到文本 (数值数组 [i]), )
.变量循环尾 ()
列表框_源.允许重画 ()

.子程序 _按钮2_被单击
.局部变量 找到数组, 整数型, , “0”
.局部变量 找到个数, 整数型
.局部变量 i, 整数型
.局部变量 启动时间, 整数型

列表框_结果.清空 ()
启动时间 = 取启动时间 ()
找到个数 = 是否在数值数组内 (数值数组, 到数值 (编辑框_数值.内容), 找到数组)
标签_结果.标题 = “搜索 ” + 编辑框_数值.内容 + “ 共找到” + 到文本 (找到个数) + “个,共耗时” + 到文本 (取启动时间 () - 启动时间) + “ms”
.变量循环首 (1, 找到个数, 1, i)
列表框_结果.加入项目 (“找到位置 ” + 到文本 (找到数组 [i]), 找到数组 [i])

.变量循环尾 ()

.子程序 _列表框_结果_列表项被选择
.局部变量 i, 整数型

i = 列表框_结果.现行选中项
列表框_源.现行选中项 = 列表框_结果.取项目数值 (i) - 1

 

快速判断数组中的数值源码

Leave a Comment