SQLite的使用

1、从官网下载SQLite(http://www.sqlite.org/download.html)安装后(Mac自带SQLite,也可直接运行下面的命令),打开终端更改目录到sqlite3文件所在的目录,输入如下命令便可以创建一个数据库,如果该数据库已存在将打开:

易语言禁止重复运行(源码)

.版本 2

.子程序 禁止重复运行, 逻辑型, 公开, 重复运行返回真;否则返回假,内部已加自动结束代码,外部无需再判断
.参数 标识, 文本型, , 建议适用长一些的任意字符串
.参数 句柄, 整数型, 可空, 用于显示已运行程序的窗口,句柄为空则不操作显示窗口
.局部变量 句柄, 整数型
.局部变量 安全结构, 安全结构
.局部变量 还原句柄, 整数型

Microsoft SQL 2000 错误代码

0 操作成功完成。
1 功能错误。
2 系统找不到指定的文件。
3 系统找不到指定的路径。
4 系统无法打开文件。
5 拒绝访问。
6 句柄无效。
7 存储控制块被损坏。
8 存储空间不足,无法处理此命令。
9 存储控制块地址无效。
10 环境错误。
11 试图加载格式错误的程序。
12 访问码无效。
13 数据无效。
14 存储器不足,无法完成此操作。
15 系统找不到指定的驱动器。
16 无法删除目录。
17 系统无法将文件移到不同的驱动器。
18 没有更多文件。
19 介质受写入保护。
20 系统找不到指定的设备。

1747576777882