在SQL SERVER中使用NChar、NVarchar和NText

  言归正传,前天同事在帮客户录数据的时候,发现有一个人的名字里有个“㛃”(念jie,同“洁”)字,但用搜狗拼音和万能五笔都打不出来,我百度了一下,找到了一篇搜狗论坛的建议帖,有人建议搜狗拼音里增加“㛃”字的输入,下面跟帖的人贴出了这个“㛃”字。

  既然字已经找到,我以为一切OK了,把它复制到飞秋里发给同事,竟然显示的是“?”!这是一个神马情况啊?
  我立马又去翻那个帖子,在下面看到了论坛版主的回复:

MsSqlSserver数据库-存储过程

写这篇存储过程的前参看了五六篇别人写的文章,看完后学到一些以前没有发现的东西,原来存储过程里有系统存储过程,原来存储过程还可以有返回值,我将把我从别人那里看到的,重新总结一下写出来。
什么是存储过程
如果你接触过其他的编程语言,那么就好理解了,存储过程就像是方法一样。竟然他是方法那么他就有类似的方法名,方法要传递的变量和返回结果,所以存储过程有存储过程名有存储过程参数也有返回值。
存储过程的优点:

存储过程的能力大大增强了SQL语言的功能和灵活性。
  可保证数据的安全性和完整性。
  通过存储过程可以使没有权限的用户在控制之下间接地存取数据库,从而保证数据的安全。
  通过存储过程可以使相关的动作在一起发生,从而可以维护数据库的完整性。
  在运行存储过程前,数据库已对其进行了语法和句法分析,并给出了优化执行方案。这种已经编译好的过程可极大地改善SQL语句的性能。
  可以降低网络的通信量。
  使体现企业规则的运算程序放入数据库服务器中,以便 集中控制。
存储过程可以分为系统存储过程、扩展存储过程和用户自定义的存储过程

IIS防御小规模DDOS攻击实例

对于低频率的DDOS可以采取这种方法。w3wp.exe是应用程序池的关联进程,当WEB访问量大时,w3wp.exe会占用大量的系统资源。在DDOS攻击下,很明显的现象就是w3wp.exe占用CPU达到100%,网站拒绝访问,这个时候远程登录服务器都很困难。针对这种情况,做如下优化:

写给我们这些浮躁的程序员

不要把祖国当母亲,应该把祖国当自己的孩子。

本不想讲这句话的,但是现实就是如此,浮躁的人群总是对社会充满了意见。我认为所有的这些浮躁都有一个共同点,就是认为自己无法改变这个社会,改变这个社会是国家的事,是其他人的事。

小时候老师总是讲祖国是母亲,我们是花朵,但是实际上我们也不是什么花朵,我们就是郑智化歌里的那根“小小的草,风吹雨打后依然不倒”。现实的社会总是充满着种种不平衡,但是浮躁并不能解决问题。有时总在想祖国并不像我的母亲,她更像是我的孩子,她还很小,经历过很多坎坷,我们经常感觉自家的孩子比不上别人的孩子的某个方面,于是对孩子多加责骂,也可能会让她花一个暑假的时间去补习。小孩子有一些成绩后也会骄傲,有时还会欺骗,我们不能容忍的是她的恶意谎言,但是她还没有到无药可救的程度,她依然还在成长。我们经常拿孩子与别人的孩子对比,而且总是发现别人孩子更好的一面,但是你是否希望与别人交换孩子呢,除了感情外你是否了解别人孩子的全部,我们需要更多的面对现实,应该在孩子成长的时候及时指出她的缺点,她不可能什么都是优秀的,所以我们应该尽自己的能力让她更好一些。你不太可能改变母亲,但是你的行动会影响孩子,你抛弃孩子,你真正的孩子将来可能也会抛弃你,所以说祖国可能并不像母亲,更像孩子,如果你把祖国当孩子,也许是另一种人生价值。

易语言API快速判断数组中的数值源码

.版本 2

.子程序 是否在数值数组内, 整数型, , 返回数值个数
.参数 数值数组, 整数型, 参考 数组
.参数 数值, 整数型
.参数 数值位置, 整数型, 参考 可空 数组, 返回该数值在数组内的位置
.局部变量 数值数组字节集, 字节集
.局部变量 长度, 整数型
.局部变量 i, 整数型
.局部变量 字节集数据, 字节集
.局部变量 数量, 整数型

1727374757682